Question : Problem: Unable to access VLAN's on Cisco Router

Attached is the current running config on the router.
Assigning a pc a ip address of 10.10.10.x (vlan-1) is working no problem, and is able to access the internet, etc.  I HAD vlan-2 and vlan-3 working as well and communicating with each other.  However, I moved the router to a different physical location on the network, and changed a few things in the routers configuration and now vlan-2 and vlan-3 are not working.  

I've checked and rechecked the physical connections, and things should be correct in that regard.  I'm under the assumption that it's a problem with the router's config, as I currently am unable to ping the gateways of vlan-2 and 3 (10.10.20.1 and 10.10.30.1) from a host on vlan-1, which I was able to do in the past.  So it's behaving as if vlan-2 and vlan-3 don't even exist.

Doing a "show arp" from the CLI returns the following:

Protocol        Address        Type        Interface
Internet        10.10.10.1      ARPA      Vlan1
Internet        10.10.10.2      ARPA      Vlan1
Internet        10.10.10.3      ARPA      Vlan1
Internet        10.10.10.15    ARPA      Vlan1
Internet        10.10.10.20    ARPA      Vlan1
Internet        10.10.10.131  ARPA      Vlan1
Internet        10.10.20.1      ARPA      Vlan2
Internet        10.10.30.1      ARPA      Vlan3

So the gateway IP's are showing up on Vlan 2 and 3, shouldn't I be able to ping them from Vlan1 hosts?  Can you see anything in my config that is causing the problem?
Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
147:
148:
149:
150:
151:
152:
153:
154:
155:
156:
157:
158:
159:
160:
161:
162:
163:
164:
165:
166:
167:
168:
169:
170:
171:
172:
173:
174:
175:
176:
177:
178:
179:
180:
181:
182:
183:
184:
185:
186:
187:
188:
189:
190:
191:
192:
193:
194:
195:
196:
Building configuration...
 
Current configuration : 5638 bytes
!
! Last configuration change at 14:24:05 PCTime Fri Mar 27 2009 by xxxxx
!
version 12.4
no service timestamps debug uptime
no service timestamps log uptime
no service password-encryption
!
hostname xxxxx
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
clock timezone PCTime -6
!
crypto pki trustpoint xxxxx
 enrollment selfsigned
 serial-number
 ip-address xxx.xxx.xxx.xxx
 revocation-check crl
 rsakeypair xxxxx-key 1024 1024
!
!
crypto pki certificate chain xxxxx
 certificate self-signed 01 
! Encryption code (I deleted for this post)
  	quit
dot11 syslog
!
!
no ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.129
ip dhcp excluded-address 10.10.10.141 10.10.10.254
!
ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
   lease 2 2
!
!
ip domain name xxxxx.com
ip name-server 68.94.156.1
ip name-server 68.94.157.1
!
multilink bundle-name authenticated
!
!
username xxxxx privilege 15 secret 5 $1$NTXp$ypu.bFlY3Kh.NuwSvFOAS/
username xxxxx privilege 15 view root password 0 xxxxx
! 
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
 description $ETH-WAN$
 ip address xxx.xxx.xxx.xxx 255.255.255.248
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 switchport access vlan 2
!
interface FastEthernet3
 switchport access vlan 3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Dot11Radio0
 no ip address
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Dot11Radio1
 no ip address
 speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Vlan2
 ip address 10.10.20.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Vlan3
 ip address 10.10.30.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Async1
 no ip address
 encapsulation slip
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface FastEthernet0 overload
!
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 1 permit 10.10.20.0 0.0.0.255
access-list 1 permit 10.10.30.0 0.0.0.255
access-list 20 remark SDM_ACL Category=16
access-list 20 permit 10.10.20.0 0.0.0.255
access-list 20 permit 10.10.30.0 0.0.0.255
access-list 21 remark SDM_ACL Category=16
access-list 21 permit 10.10.20.0 0.0.0.255
access-list 21 permit 10.10.30.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 30 remark SDM_ACL Category=16
access-list 30 permit 10.10.30.0 0.0.0.255
access-list 30 permit 10.10.20.0 0.0.0.255
access-list 31 permit 10.10.20.0 0.0.0.255
access-list 31 permit 10.10.30.0 0.0.0.255
access-list 131 remark SDM_ACL Category=16
access-list 131 permit ip 10.10.30.0 0.0.0.255 host 10.10.20.15
access-list 131 permit ip 10.10.30.0 0.0.0.255 host 10.10.20.16
access-list 131 permit ip 10.10.30.0 0.0.0.255 host 10.10.20.17
no cdp run
!
!
!
!
!
!
control-plane
!
banner login ^CCCCCOnly XXXXX Employee's may access this device. If you are not authorized disconnect now!!!^C
!
line con 0
 login local
line 1
 modem InOut
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
ntp clock-period 17180390
ntp update-calendar
ntp server 66.246.72.94 source FastEthernet0 prefer
ntp server 65.182.224.60 source FastEthernet0
ntp server 69.31.13.210
ntp server 69.31.13.210 source FastEthernet0
end
Open in New Window Select All

Answer : Problem: Unable to access VLAN's on Cisco Router

did you change the interfaces on the 20.1 and 30.1 after physical moving current router ?
Random Solutions  
 
programming4us programming4us