Otherwise, here is a skeleton configuration to copy + paste from telnet. Be sure to read through it and fill in the parts listed.
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname adsl-gw
!
!
clock timezone AEST 10
ip subnet-zero
!
!
interface Ethernet0
ip address 10.1.1.2 255.255.255.0
ip nat inside
no ip mroute-cache
!
!
! See notes above about the correct VPI/VCI numbers (PVC)
!
interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
bundle-enable
dsl operating-mode auto
hold-queue 208 in
!
! Enter your Telstra assigned username and password
! in the fields below.
!
interface Dialer0
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
no cdp enable
ppp authentication chap callin
ppp chap hostname USERNAME@bigpond
ppp chap password PASSWORD
!
ip nat inside source list 8 interface Dialer0 overload
!
! These fancy PAT translations allow internal machines to appear
! as the Telstra assigned IP address - it is not a good idea to open
! telnet/ftp - better using SSH.
!
ip nat inside source static tcp 10.1.1.11 80 interface Dialer0 80
ip nat inside source static tcp 10.1.1.11 22 interface Dialer0 22
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 8 permit 10.1.1.0 0.0.0.255
!
line con 0
exec-timeout 120 0
login local
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
password test123
login local
!
scheduler max-task-time 5000
end