Question : Problem: Comcast / Cisco router issue

Heres the senario,
I have had qwest DSL for over a year and just not happy with the speeds for the price. About 6 months ago I got comcast residental and loved the speeds. So I made the DSL just for business. Well last month I added a comcast business line in hopes of getting rid of the DSL line.  The comcast lines only came with the modems so I went ahead and purchased a couple cheap cisco 831 routers, 3 in total. So currently I have 3 interent connections coming into the house. I have vlan them so they cannot see each other via my local lan. Right now I have servers using all 3 lines.
My problem is that I cannot see my business line from my residental and vise versa (comcast residental to comcast business). I have called comcast and they keep telling me that thier network is fine and I should be able to see each router and it might be something in my config. I advised them that my server that is using the Qwest DSL connection is able to see both routers with no problems. That wasnt enought proof for them and they keep blaming my routers. I have changed the routers in my troubleshooting. At one time this was able to work till I rebooted the residental router.
Has anyone else had this problem?
I have attached each config just in case there is something there I am missing.
Thanks for looking

Residental Config
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname empire
!
!
no aaa new-model
ip subnet-zero
ip name-server 208.67.222.222
ip name-server 208.67.220.220
!
ip audit notify log
ip audit po max-events 100
ip ssh break-string
no ftp-server write-enable
!
!
!
!
!
!
interface Ethernet0
 ip address 192.168.100.5 255.255.255.0
 ip nat inside
 hold-queue 100 out
!
interface Ethernet1
 ip address dhcp
 ip nat outside
!
router rip
 version 2
 network 192.168.100.0
 no auto-summary
!
ip nat pool Home 192.168.100.5 192.168.100.5 prefix-length 24
ip nat inside source list 1 interface Ethernet1 overload
ip nat inside source static tcp 192.168.100.116 45159 interface Ethernet0 45159
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet1
no ip http server
no ip http secure-server
!
access-list 1 permit 192.168.100.0 0.0.0.255
!

!
scheduler max-task-time 5000
!
end




Business Config

!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ft-comcast
!
no aaa new-model
ip subnet-zero
ip name-server 208.67.222.222
ip name-server 208.67.220.220
!
ip audit notify log
ip audit po max-events 100
ip ssh break-string
no ftp-server write-enable
!
!
!
!
!
!
interface Ethernet0
 ip address 192.168.100.6 255.255.255.0
 ip nat inside
 hold-queue 100 out
!
interface Ethernet1
 ip address 173.8.229.169 255.255.255.252
 ip nat outside
!
ip default-gateway 173.8.229.170
ip nat inside source list 1 interface Ethernet1 overload
ip nat inside source static tcp 192.168.100.116 45159 interface Ethernet1 45159
ip nat inside source static tcp 192.168.100.11 5900 interface Ethernet1 5900
ip nat inside source static tcp 192.168.100.129 60100 interface Ethernet1 60100
ip nat inside source static tcp 192.168.100.129 60098 interface Ethernet1 60098
ip nat inside source static tcp 192.168.100.129 60097 interface Ethernet1 60097
ip nat inside source static tcp 192.168.100.129 60096 interface Ethernet1 60096
ip nat inside source static tcp 192.168.100.129 60095 interface Ethernet1 60095
ip nat inside source static tcp 192.168.100.129 60094 interface Ethernet1 60094
ip nat inside source static tcp 192.168.100.129 60093 interface Ethernet1 60093
ip nat inside source static tcp 192.168.100.129 60092 interface Ethernet1 60092
ip nat inside source static tcp 192.168.100.129 60091 interface Ethernet1 60091
ip nat inside source static tcp 192.168.100.129 60090 interface Ethernet1 60090
ip nat inside source static tcp 192.168.100.129 60020 interface Ethernet1 60020
ip nat inside source static tcp 192.168.100.129 60040 interface Ethernet1 60040
ip nat inside source static tcp 192.168.100.129 3389 interface Ethernet1 3389
ip nat inside source static tcp 192.168.100.129 25 interface Ethernet1 25
ip nat inside source static tcp 192.168.100.129 21 interface Ethernet1 21
ip nat inside source static tcp 192.168.100.129 60021 interface Ethernet1 60021
ip nat inside source static tcp 192.168.100.129 60025 interface Ethernet1 60025
ip nat inside source static tcp 192.168.100.129 60027 interface Ethernet1 60027
ip nat inside source static tcp 192.168.100.129 80 interface Ethernet1 80
ip classless
ip route 0.0.0.0 0.0.0.0 173.8.229.170
no ip http server
no ip http secure-server
!
access-list 1 permit 192.168.100.0 0.0.0.255
!
line con 0
 no modem enable
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 exec-timeout 120 0
 login local
 length 0
 transport preferred all
 transport input all
 transport output all
!
scheduler max-task-time 5000
!
end

Answer : Problem: Comcast / Cisco router issue

I was able to get this resolved via comcast. The problem was that both res and bus where on the same subnet and the way they have the network setup they will not be able to see each other. They fix they came up with is they made a special config for my res line that has it on a different subnet. The fix will be implemented tuesday.
Random Solutions  
 
programming4us programming4us