Question : Problem: Telnet access to Router from Outside

I have a router that I can telnet into from inside the network.  I need to make it so the ISP can telnet into it from the outside world.

I used this command to allow Terminal Services access to a workstation from outside:
ip nat inside source static tcp 3389 192.168.34.52 209.240.77.65 3389 extendable

So I thought that this command would work for allowing telnet access to the router from outside:
ip nat inside source static tcp 23 192.168.34.254 209.240.77.65 23 extendable

But it didn't work.  What am I doing wrong?

Answer : Problem: Telnet access to Router from Outside

Ok...

Given that this is complete
Here is some of the current config.
---------------------------------------------------------------------
interface Serial0.1 point-to-point
description connected to Internet
ip address 209.240.77.65 255.255.255.248 secondary
ip address 10.255.2.5 255.255.255.252
no ip directed-broadcast
ip nat outside
no arp frame-relay
frame-relay interface-dlci 16 IETF


There is no existing access-list that will neither prevent nor specifically authorize the ISP to telnet to your serial interface. Right now it is wide open so that anyone can telnet in...

thunder line 2

User Access Verification

Username:

However, if you want to log and/or restrict telnet access to specified addresses only:

<--standard acl, not extended-->
<--assuming that the ISP users that will be telnetting into the router are on this subnet -->
! <--create an access list that specifically identifies those that will be permitted telnet access
access-list 68 permit 209.240.0.0 0.0.255.255 log
access-list 68 permit 192.168.8.0 0.0.0.255
access-list 68 permit 192.168.10.0 0.0.0.255
!
! <-- apply the access-list to the telnet process, not to the interface -->
!
line vty 0 4
 access-class 68 in
!



Random Solutions  
 
programming4us programming4us