Question : Problem: Cisco 800 router config fails to dial?

this is my router config. i was hoping for the router to dial when the ipaddress 23.45.29.10 is required (pinged) but at present the router only dials when a spurious command is entered at the console. (only came across this be accident) and the router tries to resolve to a dns server?

I have a system on the same subnet 192.168.0.4 and the router ip is my gateway 192.168.0.2. do I need a DNS server even though I was only wishing to contact by ipaddress. My client is a  stand aloneXP system?

????????????



Using 1311 out of 8062 bytes
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
enable password password123
!
username jpacker password 0 passrrrd
!
!
!
!
ip subnet-zero
!
isdn switch-type basic-net3
!
!
!
interface Ethernet0
 ip address 192.168.0.2 255.255.255.0
 no ip directed-broadcast
 ip nat inside
 no cdp enable
!
interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
 ppp authentication chap callin
!
interface Dialer0
 ip address negotiated
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 dialer remote-name 23.45.29.10
 dialer idle-timeout 300
 dialer string 0208xxxxxxx
 dialer hold-queue 10
 dialer load-threshold 10 either
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname JPACKER
 ppp chap password 7 095F4B1B4E5D44471E04
!
ip nat inside source list 2 interface Dialer0 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 2 permit 192.168.0.2 0.0.0.25
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password PASSWORD2
 login
!
end

Answer : Problem: Cisco 800 router config fails to dial?

> access-list 2 permit 192.168.0.2 0.0.0.25

I would modify this access list to the following:
     access-list 2 permit 192.168.0.0 0.0.0.255 (this will now include your standalone XP workstation and router)

I also agree with the no ip domain-lookup statement
Random Solutions  
 
programming4us programming4us