Question : Problem: QOS issue with VOIP

I have a Cisco 1811 router at a remote office that is connected to the main site via a 5Mb link. The router was setup by someone else.  The issue is that i'm not getting anywhere near the 5Mb that i should be. The most i can get on a file transfer is 1.5Mb (shown on MRTG).  I tried tweaking the QOS settings but it didn't help. Attached is the config on the router. If anyone could shed some light on this it would be much appreciated.

thank you.
Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
147:
148:
149:
150:
151:
152:
153:
154:
155:
156:
157:
158:
159:
160:
161:
162:
163:
164:
165:
166:
167:
168:
169:
170:
171:
172:
173:
174:
175:
176:
177:
178:
179:
180:
181:
182:
183:
184:
185:
186:
187:
188:
189:
190:
191:
192:
193:
194:
195:
196:
197:
198:
199:
200:
201:
202:
203:
204:
205:
206:
207:
208:
209:
210:
211:
212:
213:
214:
215:
216:
217:
218:
219:
220:
221:
222:
223:
224:
225:
226:
227:
228:
229:
230:
231:
232:
233:
234:
235:
236:
237:
238:
239:
240:
Building configuration...
 
Current configuration : 6043 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
enable secret 5 
enable password 7 
!
username adp password 7 
username asagit password 7 
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
ip cef
!
ip dhcp pool Nolan
   network 
   option 1 
   default-router  
!
!
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
class-map match-any AutoQoS-VoIP-RTP-Trust
 match ip dscp ef 
class-map match-any AutoQoS-VoIP-Control-Trust
 match ip dscp cs3 
 match ip dscp af31 
!
!         
policy-map AutoQoS-Policy-Trust
 class AutoQoS-VoIP-RTP-Trust
  priority percent 70
 class AutoQoS-VoIP-Control-Trust
  bandwidth percent 5
 class class-default
  fair-queue
!
! 
!
!
!
interface Loopback0
 description  Office  IPT
 ip address 1.2.3.4 255.255.255.255
!
interface FastEthernet0
 ip address 10.1.1.1 255.255.255.240
 service-policy output AutoQoS-Policy-Trust
 speed 100
 full-duplex
 auto qos voip trust
 no ip redirects
 bandwidth 5000
!         
interface FastEthernet1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2
 switchport access vlan 100
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 200
 no ip address
 service-policy output AutoQoS-Policy-Trust
 auto qos voip trust 
!
interface FastEthernet3
 switchport access vlan 100
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 200
 no ip address
 service-policy output AutoQoS-Policy-Trust
 auto qos voip trust 
!
interface FastEthernet4
 switchport access vlan 100
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 200
 no ip address
 service-policy output AutoQoS-Policy-Trust
 auto qos voip trust 
!
interface FastEthernet5
 switchport access vlan 100
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 200
 no ip address
 service-policy output AutoQoS-Policy-Trust
 auto qos voip trust 
!
interface FastEthernet6
 switchport access vlan 100
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 200
 no ip address
 service-policy output AutoQoS-Policy-Trust
 auto qos voip trust 
!
interface FastEthernet7
 switchport access vlan 100
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 200
 no ip address
 service-policy output AutoQoS-Policy-Trust
 auto qos voip trust 
!
interface FastEthernet8
 switchport access vlan 100
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 200
 no ip address
 service-policy output AutoQoS-Policy-Trust
 auto qos voip trust 
!         
interface FastEthernet9
 switchport access vlan 100
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 200
 no ip address
 service-policy output AutoQoS-Policy-Trust
 auto qos voip trust 
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 1.5.9.6 255.255.255.0
 no ip redirects
 no ip mroute-cache
!
interface Vlan200
 description Phone_VLAN
 ip address 1.9.2.2 255.255.255.0
 ip helper-address 25.6.9.4
 no ip redirects
 no ip mroute-cache
!
interface Async1
 no ip address
!
router eigrp 1
 network 1.7.20.0 0.0.0.255
 network 1.1.1.0 0.0.0.15
 network 25.2.7.0
 auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.1.2
ip route 0.0.0.0 0.0.0.0 10.10.1.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drop
s" owner AutoQoS
rmon alarm 33333 cbQosCMDropBitRate.1059.1061 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33334 cbQosCMDropBitRate.1095.1097 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33335 cbQosCMDropBitRate.1131.1133 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33336 cbQosCMDropBitRate.1167.1169 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33337 cbQosCMDropBitRate.1203.1205 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33338 cbQosCMDropBitRate.1239.1241 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33339 cbQosCMDropBitRate.1275.1277 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33340 cbQosCMDropBitRate.1311.1313 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33341 cbQosCMDropBitRate.1347.1349 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33342 cbQosCMDropBitRate.1059.1061 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33343 cbQosCMDropBitRate.1095.1097 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33344 cbQosCMDropBitRate.1131.1133 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33345 cbQosCMDropBitRate.1167.1169 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33346 cbQosCMDropBitRate.1203.1205 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33347 cbQosCMDropBitRate.1239.1241 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33348 cbQosCMDropBitRate.1275.1277 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33349 cbQosCMDropBitRate.1311.1313 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
rmon alarm 33350 cbQosCMDropBitRate.1347.1349 30 absolute rising-threshold 1 333
33 falling-threshold 0 owner AutoQoS
!
line con 0
 login local
line 1
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
line vty 0 4
 login local
!
no scheduler allocate
end
Open in New Window Select All

Answer : Problem: QOS issue with VOIP

So you ping 10.10.1.1, and every other packet fails?  This wouldn't be a default route overlap issue because you wouldn't need to use your default route, for a directly connected IP address, and you are pinging from 10.10.1.9 to 10.10.1.1...

So, the question is: Why are we dropping every other packet on a serial interface, and why does it matter when you increase the byte size to 1500?

First off the reason I had you increase the Byte size to 1500 is because I always test for MTU mismatches.  Many engineers test pings and think everything is fine, but if you don't test pings over 1500 bytes then you fail to rule out MTU mismatches because packets never reach the MTU.

I will guess that this is a Metro E connection?  If so then you have an MTU mismatch in your MetroE MPLS cloud.  It is a carrier issue, and you need to make them aware of it.  The reason you are only dropping 50% of the packets is because they have some patch redundancy in their network, which is unseen by you at layer 3 because it is encapsulated.  Most likely they are adding an MPLS tag onto your 1500 byte packet and that is pushing it above the MAX MTU.

You can test this by employing a work around of setting the MTU on the interface to 1400 bytes and seeing if the problem went away.

Try setting the FE interface MTU to 1400, and then doing your ping test again.

And no if it is dropping packets it will not generate significant interface traffic.

If you think I don't know what I'm talking about my CCIE number is 6145.
Random Solutions  
 
programming4us programming4us